Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenVZ: Upgrade Ubuntu to 11.10?
10-18-2011, 01:52 AM
Post: #1
OpenVZ: Upgrade Ubuntu to 11.10?
Is it possible to update an OpenVZ VPS from Ubuntu 11.04 to 11.10 using the standard methods from within Ubuntu? Or do I need to wait for a new template and start fresh again?

Thanks.
Find all posts by this user
Quote this message in a reply
11-09-2011, 04:53 PM
Post: #2
RE: OpenVZ: Upgrade Ubuntu to 11.10?
I updated without issues.
Find all posts by this user
Quote this message in a reply
11-12-2011, 03:31 PM
Post: #3
RE: OpenVZ: Upgrade Ubuntu to 11.10?
You shouldn't have no problem updating through the standard method directly w/ Ubuntu, if you do come across any issues during it directly, please feel free to copy/paste the error here and I will assist you with getting it resolved quickly to update - for you, or anyone else having the issue.

Alien-Remix
AlienLayer - AlienVPS.com / UFOHost.net / AlienRack.com
"Abducting the Competition!" Cool
Visit this user's website Find all posts by this user
Quote this message in a reply
05-02-2012, 10:20 PM
Post: #4
RE: OpenVZ: Upgrade Ubuntu to 11.10?
I tried do-release-upgrade and got:
WARNING: this version of the GNU libc requires kernel version
2.6.24 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu10_amd64.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.15-0ubuntu10_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@tesla:/home/ray# apt-get install -t lenny linux-image-2.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package linux-image-2.6 is a virtual package provided by:
linux-image-2.6.26-1-xen-amd64 2.6.26-13lenny2
linux-image-2.6.26-1-vserver-amd64 2.6.26-13lenny2
linux-image-2.6.26-1-openvz-amd64 2.6.26-13lenny2
linux-image-2.6.26-1-amd64 2.6.26-13lenny2
linux-image-2.6.26-2-xen-amd64 2.6.26-29
linux-image-2.6.26-2-vserver-amd64 2.6.26-29
linux-image-2.6.26-2-openvz-amd64 2.6.26-29
linux-image-2.6.26-2-amd64 2.6.26-29
You should explicitly select one to install.

E: Package 'linux-image-2.6' has no installation candidate
=================
Then I tried apt-get install -t lenny linux-image-2.6.26-1-openvz-amd64 2.6.26-13lenny2 to no avail.

After running apt-get update,of course, with:
root@tesla:/home/ray# cat /etc/apt/sources.list
deb http://archive.debian.org/debian/ lenny main contrib non-free
deb http://archive.debian.org/debian-security/ lenny/updates main contrib non-free

deb http://archive.ubuntu.com/ubuntu precise main restricted universe
deb http://archive.ubuntu.com/ubuntu precise-updates main restricted universe
deb http://archive.ubuntu.com/ubuntu precise-security main restricted universe
deb http://archive.canonical.com/ubuntu precise partner
=======================

What have I overlooked, and how can I get the upgrade to run?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)
Powered By AlienLayer